Linux Video Editing Workflow

v1.0

Caroline Pimenta
Índice

1 Licence........................................................................................................................................3
2 Introduction...................................................................................................................................4
3 Certified usage scenarios.............................................................................................................5
4 Installation and technical requirements.....................................................................................6
5 Initial configuration of Kdenlive................................................................................................7
6 Extracting video from a DVD.......................................................................................................8
7 Extracting video from a Canon EOS 7D....................................................................................10
8 Extracting video from a Mini DV camera..................................................................................12
9 video editing with Kdenlive........................................................................................................13
   9.1 Editing....................................................................................................................................13
   9.2 video Effects..........................................................................................................................13
   9.3 Rendering............................................................................................................................14
10 Exporting video for the web.......................................................................................................15
11 Exporting video to HD files.......................................................................................................16
12 Exporting to DVD Video............................................................................................................18
13 Edited video example................................................................................................................22
14 List of limitations......................................................................................................................23
15 References..................................................................................................................................24
16 Acknowledgments......................................................................................................................25
1 Licence

This manual is published under the Creative Commons Attribution-Non Commercial which can be found at:

http://creativecommons.org/licenses/by-nc/3.0/
2 Introduction

The current manual describes a set of essential procedures for the proper functioning of video editing workflows in Linux systems. In particular, for the Linux Caixa Mágica distribution, versions 14 and 15, and compatible systems (e.g., Linux desktops provided by Ângulo Sólido, Magellan v2) a simple installation process was designed and certified on an extensive set of scenarios.

With this manual, all users from the previously referred versions can have access to a free, open source, easy to install video editing solution, which can be used for amateur, semi-professional or professional projects.

This document is not intended to explain the detailed procedures of video editing as for that matter some references, that were considered to be useful, can be found at the end of this document. It is rather intended to explain the logical interconnection between the different processes that compose a workflow, so that those who know or want to know more on video editing, can have a proper and certified description of the whole process - from the video extraction to the final render.

The developed solution is based on the Kdenlive video editor, and comes integrated with all the necessary components to support a complete video editing workflow. The Kdenlive interface works both in English or Portuguese, depending on the user's configuration.
3 Certified usage scenarios

Among the many possible combinations, we chose to do the certification of a subset of situations that seem to meet the needs of current video editing. The video sources considered were: DVD, Mini DV, H.264 video file and screen capture in Theora format. As relevant situations, related to exporting video into different media formats, we considered: exporting to DVD, exporting to H.264 FullHD files and exporting to H.264 HD compatible platforms like Youtube and Vimeo.

There are many other possibilities of exporting that seem to work without problems, such as MPEG-2 (which is provably the most widely supported codec) and MPEG-4 with different bitrates and resolutions. Although the results of the previous options were not put under exhaustive tests, the informal tests conducted with these two formats, indicate a very high probability of obtaining good results.

Below is a table summarizing the various certified usage scenarios in relation with their workflow.

<table>
<thead>
<tr>
<th>No.</th>
<th>Camera format</th>
<th>Software</th>
<th>Import format</th>
<th>Software</th>
<th>Export format</th>
<th>Profile name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>DVD</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>2</td>
<td>DVD</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>3</td>
<td>DVD</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>4</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>5</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>6</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>7</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>8</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
<tr>
<td>9</td>
<td>ATV</td>
<td>com2hd</td>
<td>DmhdH.264</td>
<td>com2hd</td>
<td>H.264</td>
<td>DV25000k</td>
</tr>
</tbody>
</table>
4 Installation and technical requirements

The software installation is extremely simple in the Linux distributions mentioned in the introduction. It consists only of installing the meta package task-video-editing via the Synaptic package manager or using the apt system from the command line.

For the installation from Synaptic you should:

- ensure that the contributions mirror is active
- select the package task-video-editing;
- click in Apply to install

For the installation via command line simply run:

```
[root@videoed ~]# apt-get update
[root@videoed ~]# apt-get install task-video-editing
```

To guarantee a good compatibility with the created video, it’s advisable to test your videos in multiple media players in the system, such as kaffeine, mplayer and vlc. These media players can easily be installed through Synaptic as they are available as part of the Linux distribution. It is also advisable to install the K3b burning software if you want to export DVD to Video.

Linux Caixa Mágica version 15 can be downloaded from:


The source RPMs, including the ones this solution is based on, are available here:


The minimum hardware requirements vary widely with the type of video you want to edit. The scenarios considered in this manual, which includes editing in FullHD (1920x1080 @ 25 fps), were certified using the following configuration:

- Intel Pentium Dual Core 2.6 GHZ
- 8 GB RAM
- NVIDIA Geforce2 210
- DVD recorder LG "super multi"
- Firewire card
- 64-bit Linux installation

It was seen that the previously defined memory size was more than sufficient for the requested tasks, but we noticed that the CPU was in its limits when doing multi track editing in FullHD, especially when previewing, which involves the mixing of multiple tracks, effects and transitions in real time.

So, it’s our opinion, that to properly support Full HD format edition (which is considered state of the art in terms of video quality), one should use the fastest processor available. Furthermore, it would not be unreasonable to opt for machines with more than one CPU. Note that, in terms of rendering, the processing distribution across multiple CPUs (and cores) is done automatically but it still depends on the final format used (a technical analysis of this situation is outside the scope of this document). A multi-CPU machine can also allow parallel rendering for multiple formats, lowering the waiting period.

Caroline Pimenta – 2010
http://www.carolinepimenta.eu
5 Initial configuration of Kdenlive

To launch Kdenlive for the first time, please run the following procedure:

Menu k > Sound & Video > kdenlive Video Editor

The following window should open:

Click on Next in this window and all the following ones. Kdenlive will search for all the necessary components already installed on your system and then the installation should start.

Figure 1: Initial Setup of Kdenlive - 1st window

Figure 2: Initial Setup of Kdenlive - last window
6 Extracting video from a DVD

You can extract video from a DVD with the dvd::rip software for editing in Kdenlive. In order to do this, use the following sequence from the K Menu (KDE main menu, bottom left):

Menu K > Sound & Video > dvd::rip

Once dvd::rip opens run the following sequence:

File > New project

In the Storage tab, fill in the Project Name and click on Create Project (see Figure 3).

Then go to the Rip Title tab, click on Read DVD on the table of contents, and once having opened the DVD, select the chapters you want, and click Rip selected title (s) / chapter (s) (see Figure 4).
The video extraction starts immediately and evolves according to the progress bar. The extracted files will be available in the project folder, inside a sub-folder named vob.
7 Extracting video from a Canon EOS 7D

The Canon EOS 7D digital camera records video files in MPEG-4 format with H.264 codec modes 1920x1080/25, 1920x1080/24, 1280x720/50 and 640x480/50. Unlike MiniDV cameras, the space available in the memory card is a limiting factor, so the manufacturer has opted for a format with an excellent relation of video quality and file size.

Despite the fact that the Canon EOS 7D does not support the USB Mass Storage standard (which would allow to access the content of this camera on any operating system without previous software installation), the Canon EOS 7D is automatically recognized by Linux. Once you connect it through an USB cable, a pop menu is shown that allows you to launch the DigiKam application, from which you can easily transfer the video files. An alternative way to access its content is to remove the memory card and insert it into a universal card reader, which is accessible as any other standard storage device (USB Mass Storage).

Before you start editing, you need to convert the videos using the program conv2dnxhd because the H.264 format, despite being one of the best high compression formats, it is known to create some performance problems to video editing applications [5-7]. The conversion is made to the DNxHD format, which enables better performance when editing.

To do this, create a folder with the videos and open the program conv2dnxhd:

Menu K > Sound & video > conv2dnxhd Video Converter

The following window should show up. Select the format in which the video was recorded:

In conv2dnxhd the naming 1080p@25/185 is equivalent to 1920x1080 resolution at 25 frames per second with a maximum bitrate of 185Mbps. For the remaining modes the equivalences are the same. Click OK. A dialog box will appear to let you choose the folder in which all contents will be converted (see Figure 6).
Attention:

Each folder must contain videos files with the same resolution and frame rate. If you have recorded in different modes, create separate folders and run conv2dnxhd for each of the video folders.

Select the folder and click OK.

The video conversion will begin immediately and evolve according to the progress bar. The converted files are available in the chosen folder inside a sub-folder called “output”.
8 Extracting video from a Mini DV camera

To extract your videos from a MiniDV camera rewind the tape and connect the camera to the computer through Firewire. Next, open Kdenlive and on the viewing area select the Record Monitor menu tab (see Figure 7). Click on the Record button. The recorded files will be in the folder you specify (to change the default use the Configure button).

Figure 7: Extracting video from a MiniDV Camera
9 video editing with Kdenlive

Open Kdenlive [1-3] and choose the project profile (see Figure 8):

Project > Project Settings

In Profile Settings, select the format in which the project will be edited and click OK. You should choose the highest resolution format of all the videos that will be used in the project.

9.1 Editing

Start by adding videos to the project. To do this run:

Project > Add Clip > Open

The videos will be appear on the left side of the screen area in the Project Tree. To add music, photos or images, follow the same procedure.

Start editing by using the set of five tracks that appear at the bottom of the screen. That's your timeline. Tracks 0, 1 and 2 are for the videos and 3 and 4 for audio content. To add content to the timeline, click on a clip that it's inside the Project Tree and drag it into the timeline. The edit preview goes back or forward according to a perpendicular line that moves across the media in your tracks. To play or pause use the Space key. In the Timeline menu you can find a series of commands such as cut, delete, add effects, etc..

For more information on using Kdenlive video editing see references [8-12].

9.2 video Effects

To add video effects and sound, just click on the desired clip in the timeline and choose an item from the Effect List. The effects are cumulative and may be adjusted in the Stack Effect menu tab on the left side of the screen.
If you wish to add effects like mixing or blending, you'll need to position your video clips in different tracks on your timeline (0 and 1 for example) and apply a transition effect to the clip on the top row. To perform that operation simply click on the top video clip with the right button of your mouse and Add Transition.

For more information see reference [4].

9.3 Rendering

To finalize the editing it's necessary to render your project, so that you can see the full blend of multiple tracks and effects you've created. To do this you should press the Render button, on the right side of the main toolbar:

   Render> (choose the format depending on the destination of the video)> Render to File

To determine the most appropriate choice of format for your video see chapters 10, 11 and 12.
10 Exporting video for the web

If you wish to upload your video for the web, you should export it using the formats listed below, according to the following sequences (see Figure 9):

- Render > Destination: Web Sites > Vimeo 1280x720 > Render to File
- Render > Destination: Web Sites > YouTube 1280x720 > Render to File

The rendering options for uploading to Vimeo and Youtube have been both certified, but it's recommended to choose the format "Vimeo 1280x720" either for Vimeo or Youtube because it works well in both websites and results in better video quality.
11 Exporting video to HD files

If the final destination of your video is a professional environment or any media that requires high quality video, you should export in H.264 format using the following sequence (see Figure 10):

Render > Destination: File Rendering > H.264 > H.264 25000k > Render to File

![Figure 10: Rendering to H.264](image)

**Note:**

- Some problems were found with the H.264 2 pass options.
- In addition to H.264 there are other high quality options such as MPEG-2, MPEG-4 and Theora.

The H.264 25000k profile is considered to be of great quality, but if necessary, you can create a new profile and choose a higher bitrate (see Figure 11). In order to do this you need to choose:

Render > Destination: File Rendering > H.264 > Clique sobre uma opção > create new profile.
Choose a name for the profile and change the Parameters to make the desired changes. We recommend only changing the bitrate to a value above 25000k in very special cases, where the loss of detail is visible. The remaining options generally should not be changed.

Click OK.
12 Exporting to DVD Video

If the goal is to create a DVD Video, the video should be exported to "PAL 4:3 VOB 2 pass" if the video is 4:3 or "16:9 PAL VOB 2 pass" if it's 16:9 (Fig. 12). After obtaining the final video it should be burned to a DVD (see Figure 13 - 17).

To render the video run the following:

   Render > Destination: DVD > PAL 4:3 VOB 2 pass ou PAL 16:9 VOB 2 pass > Render to File

After rendering the video, return to Kdenlive to burn the DVD through the following action:

   File > DVD Wizard

Select the DVD format according to the rendering format, click Add movie file, select the video and click Next (see Figure 13).
To create chapters in your video click Add chapter> Next. If you don't want to add any chapters please click directly on the Next button (see Figure 14).

Select Create Basic Menu, choose the title and settings and click Next (see Figure 15).
Click on Create ISO image, wait several seconds until the list is complete and click Burn. The program K3b will automatically open (see Figure 16 and 17).
The following window will appear with the K3b program. Insert a blank DVD and click *Start*. The DVD video recording should begin immediately and evolve according to the progress bar.
13 Edited video example

Go to the following link to watch an example video edited with Kdenlive:

http://carolinepimenta.eu/wbsite/the-linspotting-project
14 List of limitations

Some known limitations:

1. White noise / white artifacts: H.264 videos captured in low light conditions, when imported into Kdenlive after conversion via DNxHD, have sometimes white noise, either in preview or after rendering. In these cases we recommend the use of the original video that was extracted from the camera without conversion.

2. Screens captures: The screen captures taken with Kdenlive, when accelerated using the Speed effect, tend to render with poor quality.

3. Slow Preview speed: FullHD editing is extremely demanding in terms of CPU usage, so it's shown that in complex cases of editing (multiple tracks and effects), the preview can't be done in real time on every PC. Note that a slow preview doesn't affect in any way the final result after rendering or stops the editing process.
15 References

16 Acknowledgments

We appreciate all the technical support given by Angulo Sólido, concerning the issues of installation and technical definition of the testing and the effort of Caixa Mágica Software for the availability of the mirrors and contributing infrastructure.

We are also thankful to the various open source development projects that made this initiative possible, namely: kdenlive, mlt, ffmpeg, mplayer, xine, kaffeine, vlc, digiKam and k3b.